Troubleshooting and ErrorsCost Allocation Tags

Troubleshooting: Cost Allocation Tags

Common Symptoms

  1. “Access Denied” error when accessing AWS Cost Explorer.
  2. AWS Cost Explorer related features (e.g., budgets or cost reporting) are disabled in the Flightcontrol dashboard.
Missing cost allocation tags tooltip in AWS Cost Explorer

AWS Cost Explorer not enabled

AWS Cost Explorer is not enabled for the AWS account linked to Flightcontrol.

Solution

  1. Navigate to the Cost Explorer tab.
  2. After visiting this page, AWS will start to enable Cost Explorer for the linked account.
  3. Wait for around 24 hours for AWS to process and index the cost data.
  4. Follow steps in the Activate Cost Allocation Tags section to activate the required fc: tags.
Enable AWS Cost Explorer in the AWS Management Console

Data Unavailable in AWS Cost Explorer

Symptoms

  1. The budgets tab of a service shows the following error
  2. The estimated cost tooltip shows “Data Unavailable” error
Data unavailable in AWS Cost Explorer

Cause

The AWS account linked to Flightcontrol is either new or has just enabled AWS Cost Explorer.

Data unavailable in AWS Cost Explorer

Solution

It may take up to 24 hours for AWS to process and display cost data in the AWS Cost Explorer.

fc: tags not activated in AWS Cost Explorer

AWS can take around 24 hours to process and index any new tags attached to resources, so it may take some time for the fc: tags to show up in the cost allocations tag list.

Symptoms

  1. Flightcontrol cost tooltips shows missing cost allocation tags or service budgets tab shows missing tags.
  2. AWS Cost Explorer does not display fc: tags.
Missing cost allocation tags in AWS Cost Explorer

Possible Causes

  1. fc: tags are not activated as cost allocation tags in AWS Cost Explorer.
  2. The AWS account linked to Flightcontrol does not have the necessary permissions to activate cost allocation tags.
  3. The AWS account is a sub-account within an AWS Organization, requiring activation from the payer (root) account.

Solution

1. Check for Access Errors

If the Cost Allocation Tags tab in AWS Cost Explorer shows an access error, similar to the one below, follow the steps to activate tags from the payer/root account.

Sub-account access denied error in AWS Cost Explorer

2. Activate Cost Allocation Tags from the Payer (Root) Account

  1. Log in to the AWS payer/root account of the AWS Organization.
  2. Open the AWS Cost Explorer Console.
  3. In the left navigation pane, choose Cost Allocation Tags.
  4. Select all fc: tags to activate them as cost allocation tags.
Activating cost allocation tags in AWS Cost Explorer

3. Verify Tags in the Linked AWS Account

  1. Log back into the AWS account linked with Flightcontrol.
  2. Open the AWS Cost Explorer.
  3. Verify that fc: tags now appear as filterable cost allocation tags.
  4. Refresh the Flightcontrol dashboard to view the budget tab and enable more accurate cost reporting.